CVE-2025-65107

Medium

Description

Langfuse is an open source large language model engineering platform. In versions from 2.95.0 to before 2.95.12 and from 3.17.0 to before 3.131.0, in SSO provider configurations without an explicit AUTH_<PROVIDER>_CHECK setting, a potential account takeover may happen if an authenticated user is made to call a specifically crafted URL via a CSRF or phishing attack. This issue has been patched in versions 2.95.12 and 3.131.0. A workaround for this issue involves setting AUTH_<PROVIDER>_CHECK.

SeverityMedium
CVSS6.5
Exploit probability—
ProductLangfuse
PublishedNov 21, 2025
First seenNov 21, 2025

How to fix

Update
  • langfuse langfuse2.95.12, 3.131.0 or later

Affected products

ProductAffected versionsFixed in
langfuse langfuse2.95.0 ≤ v < 2.95.12, 3.17.0 ≤ v < 3.131.02.95.12, 3.131.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.