CVE-2025-65960
Description
Contao is an Open Source CMS. From version 4.0.0 to before 4.13.57, before 5.3.42, and before 5.6.5, back end users with precise control over the contents of template closures can execute arbitrary PHP functions that do not have required parameters. This issue has been patched in versions 4.13.57, 5.3.42, and 5.6.5. A workaround for this issue involves manually patching the Contao\Template::once() method.
How to fix
- contao contao4.13.57, 5.3.42, 5.6.5 or later
- contao/core-bundle4.13.57, 5.3.42, 5.6.5 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| contao contao | 4.0.0 ≤ v < 4.13.57, 5.0.0 ≤ v < 5.3.42, 5.4.0 ≤ v < 5.6.5 | 4.13.57, 5.3.42, 5.6.5 |
| contao/core-bundlePackagist | 4.0.0 ≤ v < 4.13.57, 5.0.0-RC1 ≤ v < 5.3.42, 5.4.0-RC1 ≤ v < 5.6.5 | 4.13.57, 5.3.42, 5.6.5 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.