CVE-2025-66024

Critical

Description

The XWiki blog application allows users of the XWiki platform to create and manage blog posts. Versions starting with 9.15 and prior to 9.15.7 are vulnerable to Stored Cross-Site Scripting (XSS) via the Blog Post Title. The vulnerability arises because the post title is injected directly into the HTML <title> tag without proper escaping. An attacker with permissions to create or edit blog posts can inject malicious JavaScript into the title field. This script will execute in the browser of any user (including administrators) who views the blog post. This leads to potential session hijacking or privilege escalation. The vulnerability has been patched in the blog application version 9.15.7 by adding missing escaping. No known workarounds are available.

SeverityCritical
CVSS9.0
Exploit probability38. percentile0.4%
ProductXwiki Blog Application
PublishedMar 4, 2026
First seenMar 4, 2026

How to fix

Update
  • xwiki blog_application9.15.7 or later
  • org.xwiki.contrib.blog:application-blog-ui9.15.7 or later

Affected products

ProductAffected versionsFixed in
xwiki blog_applicationv < 9.15.79.15.7
org.xwiki.contrib.blog:application-blog-uiMaven9.15 ≤ v < 9.15.79.15.7

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.