CVE-2025-66040

Low

Description

Spotipy is a Python library for the Spotify Web API. Prior to version 2.25.2, there is a cross-site scripting (XSS) vulnerability in the OAuth callback server that allows for JavaScript injection through the unsanitized error parameter. Attackers can execute arbitrary JavaScript in the user's browser during OAuth authentication. This issue has been patched in version 2.25.2.

SeverityLow
CVSS3.6
Exploit probability—
ProductSpotipy
PublishedNov 27, 2025
First seenNov 27, 2025

How to fix

Update
  • spotipy2.25.2 or later

Affected products

ProductAffected versionsFixed in
spotipyPyPIv < 2.25.22.25.2

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.