CVE-2025-66169
Medium
Description
Cypher Injection vulnerability in Apache Camel camel-neo4j component. This issue affects Apache Camel: from 4.10.0 before 4.10.8, from 4.14.0 before 4.14.3, from 4.15.0 before 4.17.0 Users are recommended to upgrade to version 4.10.8 for 4.10.x LTS and 4.14.3 for 4.14.x LTS and 4.17.0.
SeverityMedium
CVSS5.3
Exploit probability51. percentile0.6%
Product
Apache Camel
PublishedJan 14, 2026
First seenJan 14, 2026
Weakness typeCWE-89SQL injection
How to fix
Update
- apache camel4.10.8, 4.14.3, 4.17.0 or later
- org.apache.camel:camel-neo4j4.10.8, 4.14.3, 4.17.0 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache camel | 4.10.0 ≤ v < 4.10.8, 4.14.0 ≤ v < 4.14.3, 4.15.0 ≤ v < 4.17.0 | 4.10.8, 4.14.3, 4.17.0 |
| org.apache.camel:camel-neo4jMaven | 4.10.0 ≤ v < 4.10.8, 4.14.0 ≤ v < 4.14.3, 4.15.0 ≤ v < 4.17.0 | 4.10.8, 4.14.3, 4.17.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.