CVE-2025-66170
Description
The CloudStack Backup plugin has an improper authorization logic in versions 4.21.0.0 and 4.22.0.0. Anyone with authenticated user-account access in CloudStack 4.21.0.0+ environments, where this plugin is enabled and has access to specific APIs can list backups from any account in the environment. This vulnerability does not allow them to see the contents of the backup. Users are recommended to upgrade to version 4.22.0.1, which fixes the issue.
How to fix
- apache cloudstack4.22.0.1 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache cloudstack | 4.21.0.0 ≤ v < 4.22.0.1 | 4.22.0.1 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.