CVE-2025-66171

Medium

Description

The CloudStack Backup plugin has an improper access logic in versions 4.21.0.0 and 4.22.0.0. Anyone with authenticated user-account access in CloudStack 4.21.0.0+ environments, where this plugin is enabled and have access to specific APIs can create new VMs using backups of any other user of the environment. Backup plugin users using CloudStack 4.21.0.0+ are recommended to upgrade to CloudStack version 4.22.0.1, which fixes this issue.

SeverityMedium
CVSS6.5
Exploit probability—
ProductApache Cloudstack
PublishedMay 8, 2026
First seenMay 8, 2026
Weakness typeCWE-359CWE-359

How to fix

Update
  • apache cloudstack4.22.0.1 or later

Affected products

ProductAffected versionsFixed in
apache cloudstack4.21.0.0 ≤ v < 4.22.0.14.22.0.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.