CVE-2025-66299

High

Description

Grav is a file-based Web platform. Prior to 1.8.0-beta.27, Grav CMS is vulnerable to a Server-Side Template Injection (SSTI) that allows any authenticated user with editor permissions to execute arbitrary code on the remote server, bypassing the existing security sandbox. Since the security sandbox does not fully protect the Twig object, it is possible to interact with it (e.g., call methods, read/write attributes) through maliciously crafted Twig template directives injected into a web page. This allows an authenticated editor to add arbitrary functions to the Twig attribute system.twig.safe_filters, effectively bypassing the Grav CMS sandbox. This vulnerability is fixed in 1.8.0-beta.27.

SeverityHigh
CVSS8.8
Exploit probability—
ProductGrav
PublishedDec 1, 2025
First seenDec 1, 2025

How to fix

Update
  • getgrav grav1.8.0 or later
  • getgrav/grav1.8.0-beta.27 or later

Affected products

ProductAffected versionsFixed in
getgrav gravv < 1.8.0, 1.8.01.8.0
getgrav/gravPackagistv < 1.8.0-beta.271.8.0-beta.27

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2025-66299 · Grav · Dark Radar