CVE-2025-66305

Medium

Description

Grav is a file-based Web platform. Prior to 1.8.0-beta.27, a Denial of Service (DoS) vulnerability was identified in the "Languages" submenu of the Grav admin configuration panel (/admin/config/system). Specifically, the Supported parameter fails to properly validate user input. If a malformed value is inserted—such as a single forward slash (/) or an XSS test string—it causes a fatal regular expression parsing error on the server. This leads to application-wide failure due to the use of the preg_match() function with an improperly constructed regular expression, resulting in an error. Once triggered, the site becomes completely unavailable to all users. This vulnerability is fixed in 1.8.0-beta.27.

SeverityMedium
CVSS4.9
Exploit probability—
ProductGrav
PublishedDec 1, 2025
First seenDec 1, 2025
Weakness typeCWE-248CWE-248

How to fix

Update
  • getgrav grav1.8.0 or later
  • getgrav/grav1.8.0-beta.27 or later

Affected products

ProductAffected versionsFixed in
getgrav grav1.7.48 ≤ v < 1.8.0, 1.8.01.8.0
getgrav/gravPackagistv < 1.8.0-beta.271.8.0-beta.27

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.