CVE-2025-66308
Description
This admin plugin for Grav is an HTML user interface that provides a convenient way to configure Grav and easily create and modify pages. Prior to 1.11.0-beta.1, a Stored Cross-Site Scripting (XSS) vulnerability was identified in the /admin/config/site endpoint of the Grav application. This vulnerability allows attackers to inject malicious scripts into the data[taxonomies] parameter. The injected payload is stored on the server and automatically executed in the browser of any user who accesses the affected site configuration, resulting in a persistent attack vector. This vulnerability is fixed in 1.11.0-beta.1.
How to fix
- getgrav/grav1.8.0-beta.27 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| getgrav grav-plugin-admin | v ≤ 1.10.50 | — |
| getgrav/gravPackagist | v < 1.8.0-beta.27 | 1.8.0-beta.27 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.