CVE-2025-66310
Description
This admin plugin for Grav is an HTML user interface that provides a convenient way to configure Grav and easily create and modify pages. Prior to 1.11.0-beta.1, a Stored Cross-Site Scripting (XSS) vulnerability was identified in the /admin/pages/[page] endpoint of the Grav application. This vulnerability allows attackers to inject malicious scripts into the data[header][template] parameter. The script is saved within the page's frontmatter and executed automatically whenever the affected content is rendered in the administrative interface or frontend view. This vulnerability is fixed in 1.11.0-beta.1.
How to fix
- getgrav/grav1.8.0-beta.27 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| getgrav grav-plugin-admin | v ≤ 1.10.50 | — |
| getgrav/gravPackagist | v < 1.8.0-beta.27 | 1.8.0-beta.27 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.