CVE-2025-66311

Medium

Description

This admin plugin for Grav is an HTML user interface that provides a convenient way to configure Grav and easily create and modify pages. Prior to 1.11.0-beta.1, a Stored Cross-Site Scripting (XSS) vulnerability was identified in the /admin/pages/[page] endpoint of the Grav application. This vulnerability allows attackers to inject malicious scripts into the data[header][metadata], data[header][taxonomy][category], and data[header][taxonomy][tag] parameters. These scripts are stored in the page frontmatter and executed automatically whenever the affected page is accessed or rendered in the administrative interface. This vulnerability is fixed in 1.11.0-beta.1.

SeverityMedium
CVSS5.4
Exploit probability—
ProductGetgrav Grav-plugin-admin
PublishedDec 1, 2025
First seenDec 1, 2025

How to fix

Update
  • getgrav/grav1.11.0-beta.1 or later

Affected products

ProductAffected versionsFixed in
getgrav grav-plugin-adminv ≤ 1.10.50—
getgrav/gravPackagistv < 1.11.0-beta.11.11.0-beta.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.