CVE-2025-66388
Medium
Description
A vulnerability in Apache Airflow allowed authenticated UI users to view secret values in rendered templates due to secrets not being properly redacted, potentially exposing secrets to users without the appropriate authorization. Users are recommended to upgrade to version 3.1.4, which fixes this issue.
SeverityMedium
CVSS6.5
Exploit probability—
Product
Apache Airflow
PublishedDec 15, 2025
First seenDec 15, 2025
Weakness typeCWE-201CWE-201
How to fix
Update
- apache airflow3.1.4 or later
- apache-airflow3.1.5, 3.1.4 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache airflow | 3.1.0 ≤ v < 3.1.4 | 3.1.4 |
| apache-airflowPyPI | 3.1.0 ≤ v < 3.1.5, 3.1.0 ≤ v < 3.1.4 | 3.1.5, 3.1.4 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.