CVE-2025-66451

Medium

Description

LibreChat is a ChatGPT clone with additional features. In versions 0.8.0 and below, when creating prompts, JSON requests are sent to define and modify the prompts via PATCH endpoint for prompt groups (/api/prompts/groups/:groupId). However, the request bodies are not sufficiently validated for proper input, enabling users to modify prompts in a way that was not intended as part of the front end system. The patchPromptGroup function passes req.body directly to updatePromptGroup() without filtering sensitive fields. This issue is fixed in version 0.8.1.

SeverityMedium
CVSS6.5
Exploit probability—
ProductLibrechat
PublishedDec 11, 2025
First seenDec 11, 2025

How to fix

Update
  • librechat librechat0.8.1 or later

Affected products

ProductAffected versionsFixed in
librechat librechatv < 0.8.10.8.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.