CVE-2025-66457

High

Description

Elysia is a Typescript framework for request validation, type inference, OpenAPI documentation and client-server communication. Versions 1.4.17 and below are subject to arbitrary code execution from cookie config. When dynamic cookies are enabled (e.g. there an existing cookie schema), the cookie config is injected into the compiled route without first being sanitised. Availability of this exploit is generally low, but when combined with GHSA-hxj9-33pp-j2cc, it allows for a full RCE chain. An attack requires write access to either the Elysia app's source code (in which case the vulnerability is meaningless) or write access to the cookie config (perhaps where it is assumed to be provisioned by the environment). This issue is fixed in version 1.4.18.

SeverityHigh
CVSS8.8
Exploit probability—
ProductElysia
PublishedDec 9, 2025
First seenDec 9, 2025

How to fix

Update
  • elysiajs elysia1.4.18 or later
  • elysia1.4.18 or later

Affected products

ProductAffected versionsFixed in
elysiajs elysiav < 1.4.181.4.18
elysianpmv < 1.4.181.4.18

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.