CVE-2025-66469

Medium

Description

NiceGUI is a Python-based UI framework. Versions 3.3.1 and below are vulnerable to Reflected XSS through its ui.add_css, ui.add_scss, and ui.add_sass functions. The functions lack proper sanitization or encoding for the JavaScript context they generate. An attacker can break out of the intended <style> or <script> tags by injecting closing tags (e.g., </style> or </script>), allowing for the execution of arbitrary JavaScript. This issue is fixed in version 3.4.0.

SeverityMedium
CVSS6.1
Exploit probability—
ProductZauberzeug Nicegui
PublishedDec 9, 2025
First seenDec 9, 2025

How to fix

Update
  • zauberzeug nicegui3.4.0 or later
  • nicegui3.4.0 or later

Affected products

ProductAffected versionsFixed in
zauberzeug niceguiv < 3.4.03.4.0
niceguiPyPIv < 3.4.03.4.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.