CVE-2025-66474
Description
XWiki Rendering is a generic rendering system that converts textual input in a given syntax (wiki syntax, HTML, etc) into another syntax (XHTML, etc). Versions 16.10.9 and below, 17.0.0-rc-1 through 17.4.2 and 17.5.0-rc-1 through 17.5.0 have insufficient protection against {{/html}} injection, which attackers can exploit through RCE. Any user who can edit their own profile or any other document can execute arbitrary script macros, including Groovy and Python macros, which enable remote code execution as well as unrestricted read and write access to all wiki contents. This issue is fixed in versions 16.10.10, 17.4.3 and 17.6.0-rc-1.
How to fix
- xwiki xwiki-rendering16.10.10, 17.4.3 or later
- org.xwiki.rendering:xwiki-rendering-xml16.10.10, 17.4.3, 17.6.0-rc-1 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| xwiki xwiki-rendering | v < 16.10.10, 17.0.0 ≤ v < 17.4.3, 17.5.0 | 16.10.10, 17.4.3 |
| org.xwiki.rendering:xwiki-rendering-xmlMaven | v < 16.10.10, 17.0.0-rc-1 ≤ v < 17.4.3, 17.5.0-rc-1 ≤ v < 17.6.0-rc-1 | 16.10.10, 17.4.3, 17.6.0-rc-1 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.