CVE-2025-66516
Description
Critical XXE in Apache Tika tika-core (1.13-3.2.1), tika-pdf-module (2.0.0-3.2.1) and tika-parsers (1.13-1.28.5) modules on all platforms allows an attacker to carry out XML External Entity injection via a crafted XFA file inside of a PDF. This CVE covers the same vulnerability as in CVE-2025-54988. However, this CVE expands the scope of affected packages in two ways. First, while the entrypoint for the vulnerability was the tika-parser-pdf-module as reported in CVE-2025-54988, the vulnerability and its fix were in tika-core. Users who upgraded the tika-parser-pdf-module but did not upgrade tika-core to >= 3.2.2 would still be vulnerable. Second, the original report failed to mention that in the 1.x Tika releases, the PDFParser was in the "org.apache.tika:tika-parsers" module.
How to fix
- apache tika3.2.2 or later
- org.apache.tika:tika-core3.2.2 or later
- org.apache.tika:tika-parsers2.0.0 or later
- org.apache.tika:tika-parser-pdf-module3.2.2 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache tika | 1.13 ≤ v < 3.2.2 | 3.2.2 |
| org.apache.tika:tika-coreMaven | 1.13 ≤ v < 3.2.2 | 3.2.2 |
| org.apache.tika:tika-parsersMaven | 1.13 ≤ v < 2.0.0 | 2.0.0 |
| org.apache.tika:tika-parser-pdf-moduleMaven | 2.0.0 ≤ v < 3.2.2 | 3.2.2 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.