CVE-2025-66518

High

Description

Any client who can access to Apache Kyuubi Server via Kyuubi frontend protocols can bypass server-side config kyuubi.session.local.dir.allow.list and use local files which are not listed in the config. This issue affects Apache Kyuubi: from 1.6.0 through 1.10.2. Users are recommended to upgrade to version 1.10.3 or upper, which fixes the issue.

SeverityHigh
CVSS8.8
Exploit probability—
ProductApache Kyuubi
PublishedJan 5, 2026
First seenJan 5, 2026
Weakness typeCWE-27CWE-27

How to fix

Update
  • apache kyuubi1.10.3 or later
  • org.apache.kyuubi:kyuubi-server_2.121.10.3 or later

Affected products

ProductAffected versionsFixed in
apache kyuubi1.6.0 ≤ v < 1.10.31.10.3
org.apache.kyuubi:kyuubi-server_2.12Maven1.6.0 ≤ v < 1.10.31.10.3

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.