CVE-2025-66614

Critical

Description

Improper Input Validation vulnerability. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.14, from 10.1.0-M1 through 10.1.49, from 9.0.0-M1 through 9.0.112. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 through 8.5.100. Older EOL versions are not affected. Tomcat did not validate that the host name provided via the SNI extension was the same as the host name provided in the HTTP host header field. If Tomcat was configured with more than one virtual host and the TLS configuration for one of those hosts did not require client certificate authentication but another one did, it was possible for a client to bypass the client certificate authentication by sending different host names in the SNI extension and the HTTP host header field. The vulnerability only applies if client certificate authentication is only enforced at the Connector. It does not apply if client certificate authentication is enforced at the web application. Users are recommended to upgrade to version 11.0.15 or later, 10.1.50 or later or 9.0.113 or later, which fix the issue.

SeverityCritical
CVSS9.1
Exploit probability—
ProductApache Tomcat
PublishedFeb 17, 2026
First seenFeb 17, 2026

How to fix

Update
  • apache tomcat9.0.113, 10.1.50, 11.0.15 or later
  • org.apache.tomcat.embed:tomcat-embed-core11.0.15, 10.1.50, 9.0.113 or later
  • org.apache.tomcat:tomcat11.0.15, 10.1.50, 9.0.113 or later
  • org.apache.tomcat:tomcat-coyote11.0.15, 10.1.50, 9.0.113 or later

Affected products

ProductAffected versionsFixed in
apache tomcat9.0.1 ≤ v < 9.0.113, 10.1.1 ≤ v < 10.1.50, 11.0.1 ≤ v < 11.0.15, 9.0.0, 10.1.0, 11.0.09.0.113, 10.1.50, 11.0.15
org.apache.tomcat.embed:tomcat-embed-coreMaven11.0.0-M1 ≤ v < 11.0.15, 10.1.0-M1 ≤ v < 10.1.50, 9.0.0-M1 ≤ v < 9.0.113, 8.5.0 ≤ v ≤ 8.5.10011.0.15, 10.1.50, 9.0.113
org.apache.tomcat:tomcatMaven11.0.0-M1 ≤ v < 11.0.15, 10.1.0-M1 ≤ v < 10.1.50, 9.0.0-M1 ≤ v < 9.0.113, 8.5.0 ≤ v ≤ 8.5.10011.0.15, 10.1.50, 9.0.113
org.apache.tomcat:tomcat-coyoteMaven11.0.0-M1 ≤ v < 11.0.15, 10.1.0-M1 ≤ v < 10.1.50, 9.0.0-M1 ≤ v < 9.0.113, 8.5.0 ≤ v ≤ 8.5.10011.0.15, 10.1.50, 9.0.113

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.