CVE-2025-66627
Description
Wasmi is a WebAssembly interpreter focused on constrained and embedded systems. In versions 0.41.0, 0.41.1, 0.42.0 through 0.47.1, 0.50.0 through 0.51.2 and 1.0.0, Wasmi's linear memory implementation leads to a Use After Free vulnerability, triggered by a WebAssembly module under certain memory growth conditions. This issue potentially leads to memory corruption, information disclosure, or code execution. This issue is fixed in versions 0.41.2, 0.47.1, 0.51.3 and 1.0.1. To workaround this issue, consider limiting the maximum linear memory sizes where feasible.
How to fix
- wasmi-labs wasmi0.41.2, 0.47.1, 0.51.3 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| wasmi-labs wasmi | 0.41.0 ≤ v < 0.41.2, 0.47.0 ≤ v < 0.47.1, 0.51.0 ≤ v < 0.51.3, 1.0.0 | 0.41.2, 0.47.1, 0.51.3 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.