CVE-2025-66648

High

Description

vega-functions provides function implementations for the Vega expression language. Prior to version 6.1.1, for sites that allow users to supply untrusted user input, malicious use of an internal function (not part of the public API) could be used to run unintentional javascript (XSS). This issue is fixed in vega-functions `6.1.1`. There is no workaround besides upgrading. Using `vega.expressionInterpreter` as described in CSP safe mode does not prevent this issue.

SeverityHigh
CVSS7.2
Exploit probability—
ProductVega-functions
PublishedJan 5, 2026
First seenJan 5, 2026

How to fix

Update
  • vega-functions_project vega-functions6.1.1 or later
  • vega-functions6.1.1 or later

Affected products

ProductAffected versionsFixed in
vega-functions_project vega-functionsv < 6.1.16.1.1
vega-functionsnpmv < 6.1.16.1.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.