CVE-2025-66675

High

Description

Denial of Service vulnerability in Apache Struts, file leak in multipart request processing causes disk exhaustion. This issue affects Apache Struts: from 2.0.0 through 6.7.4, from 7.0.0 through 7.0.3. Users are recommended to upgrade to version 6.8.0 or 7.1.1, which fixes the issue. It's related to  https://cve.org/CVERecord?id=CVE-2025-64775  - this CVE addresses missing affected version 6.7.4

SeverityHigh
CVSS8.2
Exploit probability—
ProductApache Struts
PublishedDec 10, 2025
First seenDec 10, 2025
Weakness typeCWE-459CWE-459

How to fix

Update
  • apache struts6.8.0, 7.1.1 or later
  • org.apache.struts:struts2-core6.8.0, 7.1.1 or later

Affected products

ProductAffected versionsFixed in
apache struts2.0.0 ≤ v ≤ 2.3.37, 2.5.0 ≤ v ≤ 2.5.33, 6.0.0 ≤ v < 6.8.0, 7.0.0 ≤ v < 7.1.16.8.0, 7.1.1
org.apache.struts:struts2-coreMaven2.0.0 ≤ v < 6.8.0, 7.0.0 ≤ v < 7.1.16.8.0, 7.1.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2025-66675 · Apache Struts · Dark Radar