CVE-2025-67489

Critical

Description

@vitejs/plugin-rs provides React Server Components (RSC) support for Vite. Versions 0.5.5 and below are vulnerable to arbitrary remote code execution on the development server through unsafe dynamic imports in server function APIs (loadServerAction, decodeReply, decodeAction) when integrated into RSC applications that expose server function endpoints. Attackers with network access to the development server can read/modify files, exfiltrate sensitive data (source code, environment variables, credentials), or pivot to other internal services. While this affects development servers only, the risk increases when using vite --host to expose the server on all network interfaces. This issue is fixed in version 0.5.6.

SeverityCritical
CVSS9.8
Exploit probability—
Product@vitejs/plugin-rsc
PublishedDec 9, 2025
First seenDec 9, 2025

How to fix

Update
  • @vitejs/plugin-rsc0.5.6 or later

Affected products

ProductAffected versionsFixed in
@vitejs/plugin-rscnpmv < 0.5.60.5.6

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.