CVE-2025-67490
Medium
Description
The Auth0 Next.js SDK is a library for implementing user authentication in Next.js applications. When using versions 4.11.0 through 4.11.2 and 4.12.0, simultaneous requests on the same client may result in improper lookups in the TokenRequestCache for the request results. This issue is fixed in versions 4.11.2 and 4.12.1.
SeverityMedium
CVSS5.4
Exploit probability—
Product
Nextjs-auth0
PublishedDec 10, 2025
First seenDec 10, 2025
Weakness typeCWE-863Incorrect authorization
How to fix
Update
- @auth0/nextjs-auth04.11.2, 4.12.1 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| auth0 nextjs-auth0 | 4.11.0, 4.11.1, 4.12.0 | — |
| @auth0/nextjs-auth0npm | 4.11.0 ≤ v < 4.11.2, 4.12.0 ≤ v < 4.12.1 | 4.11.2, 4.12.1 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.