CVE-2025-67504

Critical

Description

WBCE CMS is a content management system. Versions 1.6.4 and below use function GenerateRandomPassword() to create passwords using PHP's rand(). rand() is not cryptographically secure, which allows password sequences to be predicted or brute-forced. This can lead to user account compromise or privilege escalation if these passwords are used for new accounts or password resets. The vulnerability is fixed in version 1.6.5.

SeverityCritical
CVSS9.1
Exploit probability—
ProductWbce Cms
PublishedDec 9, 2025
First seenDec 9, 2025

How to fix

Update
  • wbce wbce_cms1.6.5 or later

Affected products

ProductAffected versionsFixed in
wbce wbce_cmsv < 1.6.51.6.5

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.