CVE-2025-67508
Description
gardenctl is a command-line client for the Gardener which configures access to clusters and cloud provider CLI tools. When using non‑POSIX shells such as Fish and PowerShell, versions 2.11.0 and below of gardenctl allow an attacker with administrative privileges for a Gardener project to craft malicious credential values. The forged credential values are used in infrastructure Secret objects that break out of the intended string context when evaluated in Fish or PowerShell environments used by the Gardener service operators. This issue is fixed in version 2.12.0.
How to fix
- linuxfoundation gardenctl2.12.0 or later
- github.com/gardener/gardenctl-v20.0.0-20251107111549-0bdc484cb5fb or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| linuxfoundation gardenctl | v < 2.12.0 | 2.12.0 |
| github.com/gardener/gardenctl-v2Go | v < 0.0.0-20251107111549-0bdc484cb5fb | 0.0.0-20251107111549-0bdc484cb5fb |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.