CVE-2025-67721
Description
Aircompressor is a library with ports of the Snappy, LZO, LZ4, and Zstandard compression algorithms to Java. In versions 3.3 and below, incorrect handling of malformed data in Java-based decompressor implementations for Snappy and LZ4 allow remote attackers to read previous buffer contents via crafted compressed input. With certain crafted compressed inputs, elements from the output buffer can end up in the uncompressed output, potentially leaking sensitive data. This is relevant for applications that reuse the same output buffer to uncompress multiple inputs. This can be the case of a web server that allocates a fix-sized buffer for performance purposes. There is similar vulnerability in GHSA-cmp6-m4wj-q63q. This issue is fixed in version 3.4.
How to fix
- airlift aircompressor2.0.3, 3.4 or later
- io.airlift:aircompressor-v33.4 or later
- io.airlift:aircompressor2.0.3 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| airlift aircompressor | v < 2.0.3, 3.0 ≤ v < 3.4 | 2.0.3, 3.4 |
| io.airlift:aircompressor-v3Maven | v < 3.4 | 3.4 |
| io.airlift:aircompressorMaven | v < 2.0.3 | 2.0.3 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.