CVE-2025-67723
Description
Discourse is an open source discussion platform. Versions prior to 3.5.4, 2025.11.2, 2025.12.1, and 2026.1.0 have a content-security-policy-mitigated cross-site scriptinv vulnerability on the Discourse Math plugin when using its KaTeX variant. This issue is patched in versions 3.5.4, 2025.11.2, 2025.12.1, and 2026.1.0. As a workaround, the Discourse Math plugin can be disabled, or the Mathjax provider can be used instead of KaTeX.
How to fix
- discourse discourse3.5.4, 2025.11.2 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| discourse discourse | v < 3.5.4, 2025.11.0 ≤ v < 2025.11.2, 2025.12.0 | 3.5.4, 2025.11.2 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.