CVE-2025-67746
Description
Composer is a dependency manager for PHP. In versions on the 2.x branch prior to 2.2.26 and 2.9.3, attackers controlling remote sources that Composer downloads from might in some way inject ANSI control characters in the terminal output of various Composer commands, causing mangled output and potentially leading to confusion or DoS of the terminal application. There is no proven exploit and this has thus a low severity but we still publish a CVE as it has potential for abuse, and we want to be on the safe side informing users that they should upgrade. Versions 2.2.26 and 2.9.3 contain a patch for the issue.
How to fix
- getcomposer composer2.2.26, 2.9.3 or later
- composer/composer2.2.26, 2.9.3 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| getcomposer composer | 2.0.0 ≤ v < 2.2.26, 2.3.0 ≤ v < 2.9.3 | 2.2.26, 2.9.3 |
| composer/composerPackagist | 2.0.0 ≤ v < 2.2.26, 2.3.0 ≤ v < 2.9.3 | 2.2.26, 2.9.3 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.