CVE-2025-68145

Critical

Description

In mcp-server-git versions prior to 2025.12.17, when the server is started with the --repository flag to restrict operations to a specific repository path, it did not validate that repo_path arguments in subsequent tool calls were actually within that configured path. This could allow tool calls to operate on other repositories accessible to the server process. The fix adds path validation that resolves both the configured repository and the requested path (following symlinks) and verifies the requested path is within the allowed repository before executing any git operations. Users are advised to upgrade to 2025.12.17 upon release to remediate this issue.

SeverityCritical
CVSS9.1
Exploit probability—
ProductMcp-server-git
PublishedDec 17, 2025
First seenDec 17, 2025

How to fix

Update
  • mcp-server-git2025.12.18 or later
  • lfprojects model_context_protocol_servers2025.12.18 or later

Affected products

ProductAffected versionsFixed in
mcp-server-gitPyPIv < 2025.12.182025.12.18
lfprojects model_context_protocol_serversv < 2025.12.182025.12.18

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.