CVE-2025-68436

Medium

Description

Craft is a platform for creating digital experiences. In versions 5.0.0-RC1 through 5.8.20 and 4.0.0-RC1 through 4.16.16, authenticated users on a Craft installation could potentially expose sensitive assets via their user profile photo via maliciously crafted requests. Users should update to the patched versions (5.8.21 and 4.16.17) to mitigate the issue.

SeverityMedium
CVSS6.5
Exploit probability—
ProductCraftcms Craft Cms
PublishedJan 5, 2026
First seenJan 5, 2026

How to fix

Update
  • craftcms craft_cms4.16.17, 5.8.21 or later
  • craftcms/cms5.8.21, 4.16.17 or later

Affected products

ProductAffected versionsFixed in
craftcms craft_cms4.0.0.1 ≤ v < 4.16.17, 5.0.1 ≤ v < 5.8.21, 4.0.0, 5.0.04.16.17, 5.8.21
craftcms/cmsPackagist5.0.0-RC1 ≤ v < 5.8.21, 4.0.0-RC1 ≤ v < 4.16.175.8.21, 4.16.17

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.