CVE-2025-68456

Critical

Description

Craft is a platform for creating digital experiences. In versions 5.0.0-RC1 through 5.8.20 and 3.0.0 through 4.16.16, unauthenticated users can trigger database backup operations via specific admin actions, potentially leading to resource exhaustion or information disclosure. Users should update to the patched versions (5.8.21 and 4.16.17) to mitigate the issue. Craft 3 users should update to the latest Craft 4 and 5 releases, which include the fixes.

SeverityCritical
CVSS9.1
Exploit probability—
ProductCraftcms Craft Cms
PublishedJan 5, 2026
First seenJan 5, 2026

How to fix

Update
  • craftcms craft_cms4.16.17, 5.8.21 or later
  • craftcms/cms5.8.21, 4.16.17 or later

Affected products

ProductAffected versionsFixed in
craftcms craft_cms3.0.0 ≤ v < 4.16.17, 5.0.1 ≤ v < 5.8.21, 5.0.04.16.17, 5.8.21
craftcms/cmsPackagist5.0.0-RC1 ≤ v < 5.8.21, 3.0.0 ≤ v < 4.16.175.8.21, 4.16.17

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.