CVE-2025-68493

High

Description

Missing XML Validation vulnerability in Apache Struts, Apache Struts. This issue affects Apache Struts: from 2.0.0 before 2.2.1; Apache Struts: from 2.2.1 through 6.1.0. Users are recommended to upgrade to version 6.1.1, which fixes the issue.

SeverityHigh
CVSS8.1
Exploit probability—
ProductApache Struts
PublishedJan 11, 2026
First seenJan 11, 2026

How to fix

Update
  • apache struts6.1.1 or later
  • org.apache.struts:struts2-core6.1.1 or later

Affected products

ProductAffected versionsFixed in
apache struts2.0.0 ≤ v ≤ 2.3.37, 2.5.0 ≤ v ≤ 2.5.33, 6.0.0 ≤ v < 6.1.16.1.1
org.apache.struts:struts2-coreMaven2.0.0 ≤ v ≤ 2.3.37, 2.5.0 ≤ v ≤ 2.5.33, 6.0.0 ≤ v < 6.1.16.1.1
com.opensymphony:xworkMaven2.0.0 ≤ v—
org.apache.struts.xwork:xwork-coreMaven2.2.1 ≤ v—

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.