CVE-2025-68613

CriticalActively exploited (CISA KEV)

Description

n8n is an open source workflow automation platform. Versions starting with 0.211.0 and prior to 1.120.4, 1.121.1, and 1.122.0 contain a critical Remote Code Execution (RCE) vulnerability in their workflow expression evaluation system. Under certain conditions, expressions supplied by authenticated users during workflow configuration may be evaluated in an execution context that is not sufficiently isolated from the underlying runtime. An authenticated attacker could abuse this behavior to execute arbitrary code with the privileges of the n8n process. Successful exploitation may lead to full compromise of the affected instance, including unauthorized access to sensitive data, modification of workflows, and execution of system-level operations. This issue has been fixed in versions 1.120.4, 1.121.1, and 1.122.0. Users are strongly advised to upgrade to a patched version, which introduces additional safeguards to restrict expression evaluation. If upgrading is not immediately possible, administrators should consider the following temporary mitigations: Limit workflow creation and editing permissions to fully trusted users only; and/or deploy n8n in a hardened environment with restricted operating system privileges and network access to reduce the impact of potential exploitation. These workarounds do not fully eliminate the risk and should only be used as short-term measures.

SeverityCritical
CVSS9.9
Exploit probability—
Productn8n
PublishedDec 19, 2025
First seenDec 19, 2025
Added to KEVMar 11, 2026
Weakness typeCWE-913CWE-913

How to fix

CISA required action

Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.

CISA due date: Mar 25, 2026
Update
  • n8n n8n1.120.4 or later
  • n8n1.120.4, 1.121.1 or later

Affected products

ProductAffected versionsFixed in
n8n n8n0.211.0 ≤ v < 1.120.4, 1.121.01.120.4
n8nnpm0.211.0 ≤ v < 1.120.4, 1.121.0 ≤ v < 1.121.11.120.4, 1.121.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.