CVE-2025-68614

Medium

Description

LibreNMS is an auto-discovering PHP/MySQL/SNMP based network monitoring tool. Prior to version 25.12.0, the Alert Rule API is vulnerable to stored cross-site scripting. Alert rules can be created or updated via LibreNMS API. The alert rule name is not properly sanitized, and can be used to inject HTML code. This issue has been patched in version 25.12.0.

SeverityMedium
CVSS4.3
Exploit probability—
ProductLibrenms
PublishedDec 23, 2025
First seenDec 23, 2025

How to fix

Update
  • librenms librenms25.12.0 or later
  • librenms/librenms25.12.0 or later

Affected products

ProductAffected versionsFixed in
librenms librenmsv < 25.12.025.12.0
librenms/librenmsPackagistv < 25.12.025.12.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.