CVE-2025-68615
Critical
Description
net-snmp is a SNMP application library, tools and daemon. Prior to versions 5.9.5 and 5.10.pre2, a specially crafted packet to an net-snmp snmptrapd daemon can cause a buffer overflow and the daemon to crash. This issue has been patched in versions 5.9.5 and 5.10.pre2.
SeverityCritical
CVSS9.8
Exploit probability—
Product
Net-snmp
PublishedDec 23, 2025
First seenDec 23, 2025
Weakness typeCWE-119Memory buffer bounds error
How to fix
Update
- net-snmp net-snmp5.9.5 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| net-snmp net-snmp | v < 5.9.5, 5.10 | 5.9.5 |
| debian debian_linux | 11.0 | — |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.