CVE-2025-68670

Critical

Description

xrdp is an open source RDP server. xrdp before v0.10.5 contains an unauthenticated stack-based buffer overflow vulnerability. The issue stems from improper bounds checking when processing user domain information during the connection sequence. If exploited, the vulnerability could allow remote attackers to execute arbitrary code on the target system. The vulnerability allows an attacker to overwrite the stack buffer and the return address, which could theoretically be used to redirect the execution flow. The impact of this vulnerability is lessened if a compiler flag has been used to build the xrdp executable with stack canary protection. If this is the case, a second vulnerability would need to be used to leak the stack canary value. Upgrade to version 0.10.5 to receive a patch. Additionally, do not rely on stack canary protection on production systems.

SeverityCritical
CVSS9.1
Exploit probability—
ProductNeutrinolabs Xrdp
PublishedJan 27, 2026
First seenJan 27, 2026
Weakness typeCWE-121CWE-121

How to fix

Update
  • neutrinolabs xrdp0.10.5 or later

Affected products

ProductAffected versionsFixed in
neutrinolabs xrdpv < 0.10.50.10.5
debian debian_linux11.0—

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.