CVE-2025-68953
Description
Frappe is a full-stack web application framework. Versions 14.99.5 and below and 15.0.0 through 15.80.1 include requests that are vulnerable to path traversal attacks. Arbitrary files from the server could be retrieved due to a lack of proper sanitization on some requests. This issue is fixed in versions 14.99.6 and 15.88.1. To workaround, changing the setup to use a reverse proxy is recommended.
How to fix
- frappe frappe14.99.6, 15.88.1 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| frappe frappe | v < 14.99.6, 15.0.0 ≤ v < 15.88.1 | 14.99.6, 15.88.1 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.