CVE-2025-69262
Description
pnpm is a package manager. Versions 6.25.0 through 10.26.2 have a Command Injection vulnerability when using environment variable substitution in .npmrc configuration files with tokenHelper settings. An attacker who can control environment variables during pnpm operations could achieve Remote Code Execution (RCE) in build environments. This issue is fixed in version 10.27.0.
How to fix
- pnpm pnpm10.27.0 or later
- pnpm10.27.0 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| pnpm pnpm | 6.25.0 ≤ v < 10.27.0 | 10.27.0 |
| pnpmnpm | 6.25.0 ≤ v < 10.27.0 | 10.27.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.