CVE-2025-69264

High

Description

pnpm is a package manager. Versions 10.0.0 through 10.25 allow git-hosted dependencies to execute arbitrary code during pnpm install, circumventing the v10 security feature "Dependency lifecycle scripts execution disabled by default". While pnpm v10 blocks postinstall scripts via the onlyBuiltDependencies mechanism, git dependencies can still execute prepare, prepublish, and prepack scripts during the fetch phase, enabling remote code execution without user consent or approval. This issue is fixed in version 10.26.0.

SeverityHigh
CVSS8.8
Exploit probability—
ProductPnpm
PublishedJan 7, 2026
First seenJan 7, 2026
Weakness typeCWE-693CWE-693

How to fix

Update
  • pnpm pnpm10.26.0 or later
  • pnpm10.26.0 or later

Affected products

ProductAffected versionsFixed in
pnpm pnpm10.0.0 ≤ v < 10.26.010.26.0
pnpmnpm10.0.0 ≤ v < 10.26.010.26.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2025-69264 · Pnpm · Dark Radar