CVE-2025-69633
Description
A SQL Injection vulnerability in the Advanced Popup Creator (advancedpopupcreator) module for PrestaShop 1.1.26 through 1.2.6 (Fixed in version 1.2.7) allows remote unauthenticated attackers to execute arbitrary SQL queries via the fromController parameter in the popup controller. The parameter is passed unsanitized to SQL queries in classes/AdvancedPopup.php (getPopups() and updateVisits() functions).
How to fix
- PrestaShop Advanced Popup Creator (advancedpopupcreator) module1.2.7 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| PrestaShop Advanced Popup Creator (advancedpopupcreator) module | 1.1.26 ≤ v ≤ 1.2.6 | 1.2.7 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.