CVE-2025-7046

Medium

Description

The Portfolio for Elementor & Image Gallery | PowerFolio plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the Custom JS Attributes of Plugin's widgets in all versions up to, and including, 3.2.0 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The issue was partially fixed in version 3.2.0 and fully fixed in version 3.2.1

SeverityMedium
CVSS6.4
Exploit probability—
ProductPwrplugins Powerfolio
PublishedJul 4, 2025
First seenJul 4, 2025

How to fix

Update
  • pwrplugins powerfolio3.2.1 or later

Affected products

ProductAffected versionsFixed in
pwrplugins powerfoliov < 3.2.13.2.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.