CVE-2025-71404

Medium

Description

better-auth versions after v0.0.2 and before 1.1.16 contain a reflected cross-site scripting (XSS) vulnerability on the /api/auth/error page, where the value of the 'error' URL parameter is reflected as HTML without proper neutralization. An attacker who coerces a user into visiting a specially-crafted URL can execute arbitrary JavaScript in the context of the user's browser. The issue is fixed in version 1.1.16.

SeverityMedium
CVSS5.1
Exploit probability—
ProductBetter-auth
PublishedAug 1, 2026
First seenAug 1, 2026

How to fix

Affected products

ProductAffected versionsFixed in
better-authnpm0.0.2 ≤ v < 1.1.161.1.16

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.