CVE-2025-7338

High

Description

Multer is a node.js middleware for handling `multipart/form-data`. A vulnerability that is present starting in version 1.4.4-lts.1 and prior to version 2.0.2 allows an attacker to trigger a Denial of Service (DoS) by sending a malformed multi-part upload request. This request causes an unhandled exception, leading to a crash of the process. Users should upgrade to version 2.0.2 to receive a patch. No known workarounds are available.

SeverityHigh
CVSS7.5
Exploit probability—
ProductMulter
PublishedJul 17, 2025
First seenJul 17, 2025
Weakness typeCWE-248CWE-248

How to fix

Update
  • multer2.0.2 or later

Affected products

ProductAffected versionsFixed in
multernpm1.4.4-lts.1 ≤ v < 2.0.22.0.2

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2025-7338 · Multer · Dark Radar