CVE-2026-0969
High
Description
The serialize function used to compile MDX in next-mdx-remote is vulnerable to arbitrary code execution due to insufficient sanitization of MDX content. This vulnerability, CVE-2026-0969, is fixed in next-mdx-remote 6.0.0.
SeverityHigh
CVSS8.8
Exploit probability—
ProductNext-mdx-remote
PublishedFeb 12, 2026
First seenFeb 12, 2026
Weakness typeCWE-94Code injection
How to fix
Update
- next-mdx-remote6.0.0 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| next-mdx-remotenpm | 4.3.0 ≤ v < 6.0.0 | 6.0.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.