CVE-2026-100300
Description
Improper handling of exceptional conditions in the quota subsystem of Apache ZooKeeper allows an attacker able to write under the /zookeeper/quota subtree — unauthenticated on default deployments, where that subtree is world-writable — to crash the server's critical request-processing thread and render the on-disk data directory permanently unbootable. This issue affects Apache ZooKeeper up to and including 3.9.6. Users are recommended to upgrade to version 3.8.8 or 3.9.7, which fixes the issue.
How to fix
- Apache ZooKeeper3.8.8 or 3.9.7 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| Apache ZooKeeper | v ≤ 3.9.6 | 3.8.8 or 3.9.7 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.