CVE-2026-100369
Description
CliInvoke and its formerly named `AlastairLundy.CliInvoke` package are .NET libraries for invoking command-line programs and wrapping executable processes. `CliInvoke` versions 2.0.0 through 2.8.4, 2.9.0 through 2.9.3, 2.10.0 through 2.10.4, and 3.0.0-alpha.1 through 3.0.0-beta.1, as well as `AlastairLundy.CliInvoke` versions 2.0.0-alpha.1 through 2.0.0, contain an argument-injection vulnerability in `RunnerProcessFactory` on the 2.x line and `RunnerConfigurationFactory` on the 3.x line. These factories combine runner arguments, a caller-controlled target, and caller-controlled arguments into one `ProcessStartInfo.Arguments` string, allowing a double quote in the target or an argument to terminate an operating-system-level quoted region and inject unintended elements into the runner’s argument vector, potentially resulting in arbitrary command execution when a shell runner is used. The vulnerability is patched in `CliInvoke` versions 2.8.5, 2.9.4, 2.10.5, and 3.0.0-beta.2, and in `AlastairLundy.CliInvoke` version 2.0.2. No complete workaround is available; users unable to upgrade can partially mitigate the issue by removing double quotes from targets and arguments, additionally removing shell metacharacters when using shell runners, or bypassing the vulnerable factory and constructing a `ProcessConfiguration` with an explicit `ArgumentList`.
How to fix
- CliInvoke2.8.5, 2.9.4, 2.10.5, 3.0.0-beta.2 or later
- AlastairLundy.CliInvoke2.0.2 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| CliInvokeNuGet | 2.0.0 ≤ v < 2.8.5, 2.9.0 ≤ v < 2.9.4, 2.10.0 ≤ v < 2.10.5, 3.0.0-alpha.1 ≤ v < 3.0.0-beta.2 | 2.8.5, 2.9.4, 2.10.5, 3.0.0-beta.2 |
| AlastairLundy.CliInvokeNuGet | 2.0.0-alpha.1 ≤ v < 2.0.2 | 2.0.2 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.