CVE-2026-10148

Medium

Description

The Booking for Appointments and Events Calendar plugin for WordPress is vulnerable to Stored Cross-Site Scripting via multiple Elementor widgets in versions up to and including 2.4.9. This is due to insufficient input sanitization and output escaping on the 'load_manually' parameter in the render() methods of classes. This makes it possible for authenticated attackers, with Contributor-level access and above who can use Elementor, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The vulnerability was partially patched in version 2.4.8.

SeverityMedium
CVSS6.4
Exploit probability—
ProductBooking for Appointments and Events Calendar – Amelia
PublishedSep 12, 2026
First seenSep 12, 2026

How to fix

Sources list no fixed version or patch link for this vulnerability.

Affected products

ProductAffected versionsFixed in
melograno Booking for Appointments and Events Calendar – Ameliav ≤ 2.4.9—

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2026-10148 · Booking for Appointments and Events Calendar – Amelia · Dark Radar