CVE-2026-101894
Description
The decompress package for Node.js extracts archives. Prior to 10.2.2 and 11.1.4, the default decompress(input, output) API relies on lexical containment checks that do not account for the kernel following a planted symlink chain. An attacker can supply a crafted archive containing chained symlink entries so that a later entry resolves outside the output directory. This allows files outside output to be read or written, and overwriting startup scripts or configuration can lead to remote code execution. The maintained @xhmikosr/decompress package is fixed in 10.2.2 and 11.1.4, but the separately affected unmaintained decompress package remains unpatched through 4.2.1. This vulnerability results from a bypass of the incomplete hardening for CVE-2026-53486. @xhmikosr/decompress is fixed in versions 10.2.2 and 11.1.4.
How to fix
- @xhmikosr/decompress11.1.4, 10.2.2 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| @xhmikosr/decompressnpm | 11.0.0 ≤ v < 11.1.4, v < 10.2.2 | 11.1.4, 10.2.2 |
| decompressnpm | v ≤ 4.2.1 | — |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.